Postingan

Terlihat baik dimata orang itu tidak penting

Terlihat baik dimata orang itu tidak penting, yang penting itu kita benar menjalankan apa yang menjadi kewajiban kita selalu meningkatkan iman dan taqwa kita.



Allah akan memperlihatkan sesuatu menurut orang lain tidak baik pada diri kita agar kita bisa lebih mengoreksi diri menjadi lebih baik dari sebelumnya, walaupun belum tentu benar apa yang dilihat orang lain tentang keburukan kita.



Manusia biasa tidak ma'sum, yang terjaga dari kesalahan seperti nabi dan rosul, kita manusia berpotensi salah.



Tapi Dengan kesalahan itu bagaimana kita menjadikannya sebagai bahan untuk muhasabah (mengoreksi diri).



Kisah Sekelas ulama' soleh yang pada jaman dulu melakukan riset. Untuk mencatat kebaikan dan keburkan dalam sehari.



1. Setiap melakukan kebaikan/pahala maka saku/kantong kanan akan disi dengan kerikil.
2. Setiap melakukan kesalahan/dosa maka saku/kantong kiri akan diisi kerikil.



Setelah 24jam apa yang terjadi? Ternyata saku/kantong kiri yang artinya kesalahan/dosa lebih banyak daripada keba…

Jangan mengira diriku sebagai orang baik

Jangan mengira diriku sebagai orang baik, dan bisa jadi aku tak seburuk yang kau kira, karena untuk tau semua itu kau harus mengajakku safar (jalan-jalan) untuk mengenal lebih dekat tentang diriku.



Seperti yang dilakukan sahabat nabi umar bin Khattab Ra, salah satu tolak ukur mengenal seseorang ialah dengan mengajaknya bepergian selama 10 hari atau lebih, maka kau akan tau sikap aslinya.



Selamat malam sabtu.
Jangan lupa besok ngaji.

Puisi Cinta Bertepuk Sebelah Tangan Yang Menyakitkan

Mungkin dengan begitu engkau bisa menikmati bagaimana rasanya berkenalan, bagimana nikmatnya berjuang, bagaimana rasanya ta'aruf, bagaiman rasanya bermunajat kepada Allah agar dia menjadi jodohmu ketika orang-orang pada enak2 tidur.



Dan "merasakan bagaimana rasanya itu semua tidak terkabul"



Selamat menikmati hidup dalam banjir air hujan, bukan banjir air mata yang membuatmu terpuruk dalam lingkaran cinta segi tiga bermuda. 

Limit Otomatis Simple Queues Mikrotik Pada DHCP Client Leases

Gambar
Yang ingin melimit otomatis setiap device yang konek dengan jaringan mikrotik kita melalui DHCP server, berikut ini script untuk melimit secara otomatis.



Jadi cara kerjanya yaitu, ketika ada device connect di DHCP server, maka secara otomatis IP dari device yang connect tersebut terlimit di simple queues.



Lihat gambar dibawah ini pengaturan dhcp pada mikrotik saya:







#Lease to Simple Queues
#V.1 By Virtual IT Export

:local queueName "Client- $leaseActMAC";

:if ($leaseBound = "1") do={
/queue simple add name=$queueName target=($leaseActIP . "/32") limit-at=1024k/1024k max-limit=1024k/1024k comment=[/ip dhcp-server lease get [find where active-mac-address=$leaseActMAC && active-address=$leaseActIP] host-name];
} else={
/queue simple remove $queueName
}



Semoga bermanfaat.

Debrick TP-link TL-MR3420 V1 karena Gagal Install Openwrt

Gambar
Dari pengalaman saya yang punya router jadul dengan type tl-mr3420 v1.3 saat itu saya mencoba untuk install openwrt melalui GUI upgrade TP-link namun salah pilih firmware hingga akhirnya router mati suri alias nyala lampu power saja dan tidak bisa apa-apa.



berbagai cara aku coba dengan mengikuti tutorial-tutorial diberbagai blog dan di forum/group facebook yang membahas tentang openwrt ini, namun nihil hasilnya.



mati sekitar 8 bulan, saya mencoba kembali otak atik, dan saya mendapat clue dan bisa saya pahami dari group fb openwrt Indonesia, akhitnya bisa hidup kembali.



PERSIAPAN:



USB TTLKabel LANSoftware TFTP server download disini: http://tftpd32.jounin.net/tftpd32_download.htmlFirmware asli TP-link download disini: https://www.tp-link.com/en/download/TL-MR3420_V1.htmlSoftware Putty download disini: https://www.putty.org



STEP 1



copy firmware asli tp-link ke direktori instalasi tftp server, seperti ini.







STEP 2



Matikan router dan Install driver USB-TTL di komputer, saya menggunakan windows 10 …

Install Webserver di Openwrt, uhttpd + php7 + Mysql-server

Wajib Extroot, Berikut ini dokumentasi saya saat install webserver di router linux openwrt, sengaja tidak disertai dengan penjelasan yang lengkap karena memang hanya sebuah dokumentasi saja biar nanti kalau lupa bisa merujuk kembali.



UPDATE



opkg update



INSTALL PHP-7



opkg install php7
opkg install php7-cgi







Edit dan tambahkan kode dibawah ini pada: /etc/config/uhttpd



list interpreter ".php=/usr/bin/php-cgi"
option index_page index.php



opkg install php7-mod-ctype php7-mod-curl php7-mod-dom php7-mod-exif php7-mod-fileinfo php7-mod-ftp php7-mod-gd php7-mod-gettext php7-mod-gmp php7-mod-hash php7-mod-iconv php7-mod-json php7-mod-ldap php7-mod-mbstring php7-mod-mcrypt php7-mod-mysql php7-mod-openssl php7-mod-pcntl php7-mod-pdo php7-mod-pdo-mysql php7-mod-pdo-pgsql php7-mod-pdo-sqlite php7-mod-pgsql php7-mod-session php7-mod-simplexml php7-mod-soap php7-mod-sockets php7-mod-sqlite php7-mod-sqlite3 php7-mod-sysvmsg



opkg install php7-mod-sysvsem php7-mod-sysvshm php7-mod-tokenizer php7-mo…

Cinta Yang Tulus, Tapi Menyakitkan

Jatuh cinta membuatku menjadi aneh dan berbeda, entah apa yang membuatku rela menunggu dan menutup pintu hati ini untuk orang lain, hanya memilih dia yang tak pasti akan menjadi milikku.



sebenarnya aku sudah tau kalau dia sudah tidak punya rasa denganku, tapi rasaku sudah terlanjur aku kunci untuk dia (sulit rasanya lepas dari dia) terlanjur aku berikan seutuhnya untuk dia, entah takdir apa yang aku alami ini, 3 tahun menjalani status yang tidak pasti, berharap yang tidak pasti.



selama ini aku lebih memilih mengalah dalam memanage sebuah perasaan, aku lebih mementingkan perasaan dia daripada perasaanku sendiri, aku selalu mencoba memberi perhatian lebih kepadanya walaupun semua itu terasa tiada artinya, tak ada balasan apapun yang membuatku lebih baik.



aku rela sakit untuk dia, aku rela menderita demi dia, apakah ini benar-benar cinta atau hanya nafsu belaka, kucoba mencari petunjuk, aku memohon pertolongan kepada tuhan Allah SWT, memohon petunjuk dan bimbingan sesuai dengan ajaran islam…